درخواست های ارتباط
جستجو
    لیست دوستان من
    صندوق پیام
    همه را دیدم
    • در حال دریافت لیست پیام ها
    صندوق پیام
    رویدادها
    همه را دیدم
    • در حال دریافت لیست رویدادها
    همه رویدادهای من
    تخفیف های وب سایت
    همه تخفیف ها

    عضویت در

    کانال تلگرام

    توسینسو

    اطلاعات مطلب
      مدرس/نویسنده
      فربد رستم صولت
      امتیاز: 15385
      رتبه:40
      17
      32
      66
      757
      فربد رستم صولت هستم تازه وارد به دنیای شبکه ، شبکه های مایکروسافتی ، مجازی سازی ، هاستینگ ، ویپ ، میکروتیک ، برنامه نویس زبان G ،برنامه نویس سخت افزار های صنعتی و غیر صنعتی طراح و سازنده و برنامه نویس روبات های صنعتی و غیر صنعتی ، پرنده و زمینی و همچنین علاقمند به ارتباط تمام اشیا به یکدیگر هستم و دارم کارهایی میکنم. بدلیل تازه کار بودن سوابق زیادی ندارم از کلاس چهارم ابتدایی وارد حوضه IT شدم و تا الان این ادامه داشته و خواهد داشت. پروفایل کاربر
      دوره های مرتبط
      دوره های توسینسو دوره آموزشی بین المللی میکروتیک MTCNA با تدریس محمد جواد صبری
      دوره آموزشی بین المللی میکروتیک MTCNA با تدریس محمد جواد صبری
      مدرس: محمد جواد صبری
      این دوره را در 10 قسط خریداری کنید
      سناریوهای کاربردی در میکروتیک
      سناریوهای کاربردی در میکروتیک
      مدرس: پوریا تعبدی
      این دوره را در 3 قسط خریداری کنید
      آموزش نرم افزار مانیتورینگ سبک و قدرتمند The Dude
      آموزش نرم افزار مانیتورینگ سبک و قدرتمند The Dude
      مدرس: رضا محمدی
      این دوره را در 1 قسط خریداری کنید
      دوره آموزشی جامع امنیت در تجهیزات میکروتیک
      دوره آموزشی جامع امنیت در تجهیزات میکروتیک
      مدرس: آرش ترابی
      این دوره را در 10 قسط خریداری کنید
      دوره آموزشی پروژه های دنیای واقعی میکروتیک
      دوره آموزشی پروژه های دنیای واقعی میکروتیک
      مدرس: بهزاد حسن زاده
      این دوره را در 10 قسط خریداری کنید
      دوره آموزشی بین المللی MTCRE میکروتیک با آرش حیدری
      دوره آموزشی بین المللی MTCRE میکروتیک با آرش حیدری
      مدرس: آرش حیدری
      این دوره را در 2 قسط خریداری کنید
       آموزش دوره MTCNA میکروتیک
      آموزش دوره MTCNA میکروتیک
      مدرس: بهزاد حسن زاده
      این دوره را در 5 قسط خریداری کنید
      دوره آموزشی نرم افزار مانیتورینگ و پیکربندی میکروتیک The Dude
      دوره آموزشی نرم افزار مانیتورینگ و پیکربندی میکروتیک The Dude
      مدرس: امیر اکبری زاده
      این دوره را در 3 قسط خریداری کنید
      دوره جامع مهندسی کنترل ترافیک میکروتیک MTCTCE
      دوره جامع مهندسی کنترل ترافیک میکروتیک MTCTCE
      مدرس: پوریا تعبدی
      این دوره را در 6 قسط خریداری کنید
      دوره آموزشی بین المللی میکروتیک MTCRE با جواد عابدی نیا
      دوره آموزشی بین المللی میکروتیک MTCRE با جواد عابدی نیا
      مدرس: جواد عابدی نیا
      این دوره را در 21 قسط خریداری کنید
      دوره آموزشی بین المللی میکروتیک MTCNA با تدریس پوریا تعبدی
      دوره آموزشی بین المللی میکروتیک MTCNA با تدریس پوریا تعبدی
      مدرس: پوریا تعبدی
      این دوره را در 8 قسط خریداری کنید
      دوره آموزشی بین المللی میکروتیک MTCUME با تدریس پوریا تعبدی
      دوره آموزشی بین المللی میکروتیک MTCUME با تدریس پوریا تعبدی
      مدرس: پوریا تعبدی
      این دوره را در 4 قسط خریداری کنید
      دوره آموزشی سناریوهای کاربردی در میکروتیک
      دوره آموزشی سناریوهای کاربردی در میکروتیک
      مدرس: محمد جواد صبری
      این دوره را در 17 قسط خریداری کنید

      ارسال لاگ های میکروتیک به ایمیل

      تاریخ 14 ماه قبل
      نظرات 4
      بازدیدها 298
      با سلام ، شاید خیلی از شماها میخواستید لاگ های میکروتیک رو جاییی ذخیره کنید اما یا میکروتیک فضا نداشته یا سرور مخصوص syslog نداشتید ، نگران نباشید خیلی راحت با این اسکریپت میتونید لاگ هارو هم به ایمیل خودتون ارسال کنید ، فقط باید طبق آموزش قبلی من که ارسال بکاپ به ایمیل بود سرویس ایمیل رو در میکروتیک تنظیم کنید
      این کد اسکریپت ، نحوه کار اسکریپت هم مثل اسکریپت قبلی ارسال ایمیل هست
      :log info "Mikrotik log E-mail start  . . . "
      /log print file=log
      :log info "Makeing LOG file process pausing for 10s so it complete creating log file"
      :delay 10s
      :log info "Start Sending log File via Email using GMAIL SMTP  . . ."
      / tool e-mail send to=youremail@email subject=([/system clock get date].\ " ".\ [/system clock get time] . \ " MikroTik log file") body="MikroTik email log"  file=log
      :log info ("log file e-mail status:  ".\ [/tool e-mail get last-status])
      :delay 40s
      :if ([/tool e-mail get last-status] = "failed") do={log error "Can`t send E-mail cheak it...";log error "Restart E-mail log file";[/system script run system_log_email ]} else={:log warning ("log e-mail status:  ".\ [/tool e-mail get last-status]);:log info "log e-mail Finished";:log info "Deleting log File. All Done.";/file remove log;}
      
      
      youremail@emai رو باید بر اساس ایمیل مقصد خودتون تنظیم کنید
      برچسب ها
      ردیفعنوان
      1ارسال بکاپ در میکروتیک به ایمیل
      2ارسال لاگ های میکروتیک به ایمیل
      3ارسال بکاپ میکروتیک به سرورftp
      دورهمجموعه کل دوره
      مطالب مرتبط

      در حال دریافت اطلاعات

      نظرات
      • ممنون از آموزش خوبتون

        دو تا سوال
        اول اینکه این اسکریپت هر چند دیقه و یا چند ساعت اجرا میشه
        و دوم اینکه چطور میشه تنظیم کرد که فایل اتچ نکنه و لاگ رو توی خود ایمیل ارسال کنه چون توی فایل خیلی یه هم ریخته هستش
      • توی خود ایمیل نمیفرسته
        و اینکه بستگی داره شما برای چه زمانی تنظیم کنید
      • ممنون
        اگر که بخام زمانی که یک event خاص روی میده برام ایمیل ارسال بشه چی ؟؟؟
        مثلا زمانی که یکی از خط های اینترنت Faile میشه
      • باید بیاید یک دستور if بنویسید و در اون این کد بالا رو بزارید که وقتی شرط برقرار شد بیاد کد بالا رو اجرا کنه و ایمیل بده

      برای ارسال نظر ابتدا به سایت وارد شوید