در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

ارسال لاگ های میکروتیک به ایمیل

با سلام ، شاید خیلی از شماها میخواستید لاگ های میکروتیک رو جاییی ذخیره کنید اما یا میکروتیک فضا نداشته یا سرور مخصوص syslog نداشتید ، نگران نباشید خیلی راحت با این اسکریپت میتونید لاگ هارو هم به ایمیل خودتون ارسال کنید ، فقط باید طبق آموزش قبلی من که ارسال بکاپ به ایمیل بود سرویس ایمیل رو در میکروتیک تنظیم کنید

این کد اسکریپت ، نحوه کار اسکریپت هم مثل اسکریپت قبلی ارسال ایمیل هست

:log info "Mikrotik log E-mail start  . . . "
/log print file=log
:log info "Makeing LOG file process pausing for 10s so it complete creating log file"
:delay 10s
:log info "Start Sending log File via Email using GMAIL SMTP  . . ."
/ tool e-mail send to=youremail@email subject=([/system clock get date].\ " ".\ [/system clock get time] . \ " MikroTik log file") body="MikroTik email log"  file=log
:log info ("log file e-mail status:  ".\ [/tool e-mail get last-status])
:delay 40s
:if ([/tool e-mail get last-status] = "failed") do={log error "Can`t send E-mail cheak it...";log error "Restart E-mail log file";[/system script run system_log_email ]} else={:log warning ("log e-mail status:  ".\ [/tool e-mail get last-status]);:log info "log e-mail Finished";:log info "Deleting log File. All Done.";/file remove log;}

youremail@emai رو باید بر اساس ایمیل مقصد خودتون تنظیم کنید

#لاگ_میکروتیک #log_سرور_میکروتیک #راه_اندازی_log_سرور_در_میکروتیک #مشکل_در_نگهداری_لاگ #راه_اندازی_لاگ_سرور_میکروتیکی #راه_اندازی_لاگ_سرور_برای_میکروتیک #ارسال_لاگ_ها_به_ایمیل
عنوان
1 ارسال بکاپ در میکروتیک به ایمیل رایگان
2 ارسال لاگ های میکروتیک به ایمیل رایگان
3 آموزش ارسال بکاپ میکروتیک به FTP سرور رایگان
زمان و قیمت کل 0″ 0
4 نظر
مرتضی بهزادی مقدم

ممنون از آموزش خوبتون

دو تا سوال

اول اینکه این اسکریپت هر چند دیقه و یا چند ساعت اجرا میشه

و دوم اینکه چطور میشه تنظیم کرد که فایل اتچ نکنه و لاگ رو توی خود ایمیل ارسال کنه چون توی فایل خیلی یه هم ریخته هستش

فربد رستم صولت

توی خود ایمیل نمیفرسته

و اینکه بستگی داره شما برای چه زمانی تنظیم کنید

مرتضی بهزادی مقدم

ممنون

اگر که بخام زمانی که یک event خاص روی میده برام ایمیل ارسال بشه چی ؟؟؟

مثلا زمانی که یکی از خط های اینترنت Faile میشه

فربد رستم صولت

باید بیاید یک دستور if بنویسید و در اون این کد بالا رو بزارید که وقتی شرط برقرار شد بیاد کد بالا رو اجرا کنه و ایمیل بده

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره تابستانه می تونی امروز ارزونتر از فردا خرید کنی ....