تا %60 تخفیف خرید برای 7 نفر با صدور مدرک فقط تا
00 00 00
در توسینسو تدریس کنید

آموزش راه اندازی تانل EOIP بر روی روترهای میکروتیک

با سلام خدمت دوستان و همه ITPro های عزیز ...در ادامه اموزش Tunneling بر روی میکروتیک که دو نوع تانل IPIP و GRE رو بررسی کرده بودیم اینبار در این آموزش قصد دارم نحوه پیکربندی تانل EOIP به دو صورت لایه 3 خدمت شما دوستان اموزش بدم.iهمان طور که در آموزش های قبلی گفتیم زمانی از ارتباط تانل استفاده میکنیم که بخواهیم بین چندین شبکه دور از هم ( از نظر جغرافیایی ) با هم در ارتباط باشند و این ارتباط یک ارتباط امن بین دو شبکه باشد از Tunneling استفاده میکنیم که در این آموزش تانل EOIP یا Ethernet Over Internet Protocol می باشد رو در حالت لایه 3 بررسی خواهیم کرد.

پیکربندی تانل EOIP بر روی میکروتیک به صورت لایه 3


برای پیکربندی تانل سناریو زیر را در نظر بگیرید که در این سناریو دو شبکه داخلی وجود دارد که هر یک از شبکه ها با استفاده از اترنت 2 روتر میکروتیک به دنیایی مجازی اینترنت ارتباط دارند و هر کدام بر روی این اترنت یک IP Public رو در اختیار خودشون دارند. برای شروع کار ما باید اول تنظیمات اختصاص دادن آدرس های IP بر روی اترنت های هر دو میکورتیک رو انجام بدیم که این کار را به دو صورت دستوری و گرافیکی انجام میدهیم.

MikroTik-1 :

[itpro@MikroTik-1] > ip address add address=172.16.30.1/32 interface=ether1
[itpro@MikroTik-1] > ip address add address=100.10.10.2/30 interface=ether2

بعد از اختصاص دادن ادرس IP بر روی اترنت های 1 و 2 روتر باید در قسمت ip > routes هم یک static route به صورت دیفالت به سمت اینترنت بنویسیم که برای این کار از دستور زیر استفاده میکنیم :

[itpro@MikroTik-1] > ip routes add dst-address=0.0.0.0/0 gateway=100.10.10.1

برای انجام 3 دستور بالا به صورت گرافیکی طبق تصاویر زیر میتوانیم انجام دهیم :

1.1

1.2

بعد از انجام مراحل بالا همین کارها را بر روی روتر دوم نیز به صورت زیر انجام میدهیم:

MikroTik-2 :

[itpro@MikroTik-2] > ip address add address=185.15.60.1/32 interface=ether1
[itpro@MikroTik-2] > ip address add address=200.20.20.2/30 interface=ether2

بعد از اختصاص دادن ادرس IP بر روی اترنت های 1 و 2 روتر باید در قسمت ip > routes هم یک static route به صورت دیفالت به سمت اینترنت بنویسیم که برای این کار از دستور زیر استفاده میکنیم :

[itpro@MikroTik-2] > ip routes add dst-address=0.0.0.0/0 gateway=200.20.20.1

برای انجام 3 دستور بالا به صورت گرافیکی طبق تصاویر زیر میتوانیم انجام دهیم :

2.1

2.2

بعد از اتمام ست کردن ادرس های IP و مسیردهی روتر به سمت اینترنت با static route اینبار نوبت به فعال کردن EOIP Tunnel بر روی روترها می بشاد.

پیکربندی تانل EOIP بر روی روترها


برای اینکه بتوانیم ارتباط تانل را بین دو روتر برقرار کنیم مراحل زیر را انجام میدهیم:

MikroTik-1 :

[itpro@MikroTik-1] > interface eoip
[itpro@MikroTik-1] /interface eoip> add remote-address=200.20.20.2 tunnel-id=0

نکته : فیلد Tunnel ID که به صورت پیشفرض عدد 0 می باشد باید در هر دو روتر برابر باشد.

نکته : در صورتی که بر روی یک روتر چندین تانل EoIP داریم نباید Tunnel ID انها برابر باشد.

بعد از فعال کردن تانل باید یک آدرس IP بر روی اینترفیس تانل طبق تصویر سناریو اضافه کنیم که آن رو هم از دستور زیر انجام میدیم :

[itpro@MikroTik-1] > ip address add address=192.168.1.1/30 interface=eoip-tunnel1

مراحل بالا به صورت گرافیکی :

1.3

1.4

iهمچنین مراحل بالا را بر روی روتر دوم نیز انجام میدهیم :

MikroTik-2 :

[itpro@MikroTik-2] > interface eoip
[itpro@MikroTik-2] /interface eoip> add remote-address=100.10.10.2 tunnel-id=0

و ست کردن IP بر روی اینترفیس تانل :

[itpro@MikroTik-2] > ip address add address=192.168.1.2/30 interface=eoip-tunnel1

به صورت گرافیکی داریم :

2.3

2.4

بعد از اینکه تانل EoIP بین دو روتر برقرار شد و برای انکه دسترسی به شبکه های داخلی از طریق تانل ایجاد شده صورت بگیرد باید بر روی روترها یک static روت به شکل زیر بنویسیم :

MikroTik-1 :

[itpro@MikroTik-1] > ip routes add das-address=185.15.60.1/32 gateway=192.168.1.1

MikroTik-2 :

[itpro@MikroTik-2] > ip routes add das-address=172.16.30.1/32 gateway=192.168.1.2

بعد از نوشتن دو static route بالا حال اگر از یکی از شبکه های داخلی رو از مقابل ping بگیریم نتیجه کارهای خود را خواهیم دید که ارتباط از طریق تانل EoIP که ایجاد کردیم خواهد بود :

[itpro@MikroTik-2] > ping 172.16.30.1
HOST                                     SIZE TTL TIME  STATUS
172.16.30.1                                    57 255 64ms
172.16.30.1                                    56 255 61ms
172.16.30.1                                    50 255 69ms
172.16.30.1                                    50 255 54ms

موفق و ITPro باشید.

نویسنده : بهزاد حسن زاده

منبع : جزیره میکروتیک وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی است

نظر شما
برای ارسال نظر باید وارد شوید.
3 نظر
افرادی که این مطلب را خواندند مطالب زیر را هم خوانده اند
تنظیمات حریم خصوصی
تائید صرفنظر