در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

آموزش پیکربندی تانل GRE بر روی روترهای میکروتیک

با سلام خدمت همه دوستان و ITPro های عزیز ...در ادامه اموزش های میکروتیک در این آموزش قصد دارم نحوه راه اندازی تانل GRE بین روترهای میکروتیک رو خدمت شما کاربران عزیز آموزش بدم.وقتی ما بخواهیم چندین شبکه دور از هم (از نظر جغرافیایی) از گزینه تانل استفاده میکنیم. برای مثال سناریو زیر رو در نظر بگیرید:

1

در سمت چپ این تصویر یک روتر میکروتیک رو داریم با نام MikroTik-1 که این روتر از طریق اترنت 1 با شبکه 172.16.30.1 و از طریق اترنت 2 خودش که IP Public به آدرس 100.10.10.2 رو داره به دنیای اینترنت متصل هست و همچنین در سمت راست تصویر باز یک روتر میکروتیک رو با نام MikroTik-2 که همانند روتر قبلی از طریق اترنت 1 به شبکه داخلی 172.16.50.1 و از طریق اترنت 2 به سمت اینترنت با IP Public به ادرس 200.20.20.2 دسترسی دارد.برای اینکه بخواهیم هر دو شبکه رو بهم ارتباط دهیم بطوری که packet های ما از بستر امن رد و بدل بشن میایم بین این دو روتر یک tunnel راه اندازی میکنیم به طوری که بعد از این همه ارتباط بین این دو شبکه از داخل این Tunnel رد و بدل بشن. برای اینکه نحوه پیکربندی تانل رو شما دوستان یادبگیرید من همین سناریو (تصویر بالا) را برای شما کانفیگ میکنم.

اختصاص دادن IP ادرس ها و نوستن یک دیفالت Route به سمت اینترنت بر روی روتر ها


برای شروع ما باید ادرس IP های مربوط به روتر شماره 1 خودمان را طبق دستورات و یا با استفاده از تصویر زیر بر روی روتر مورد نظر انجام دهیم و در آخر یک static route به سمت اینترنت رو به جدول Routing روتر اضافه کنیم برای اینکه شبکه داخلی بتونه از اینترنت نیز استفاده بکند.

MikroTik-1

[itpro@MikroTik-1] > ip address add address=172.16.30.1/32 interface=ether1
[itpro@MikroTik-1] > ip address add address=100.10.10.2/30 interface=ether2
[itpro@MikroTik-1] > ip routes add dst-address=0.0.0.0/0 gateway=100.10.10.1

و یا به صورت گرافیکی :

1

2

MikroTik-2

[itpro@MikroTik-2] > ip address add address=172.16.50.1/32 interface=ether1
[itpro@MikroTik-2] > ip address add address=200.20.20.2/30 interface=ether2
[itpro@MikroTik-2] > ip routes add dst-address=0.0.0.0/0 gateway=200.20.20.1

و یا به صورت گرافیکی :

3

4

نحوه پیکربندی GRE Tunnel بر روی روترها


بعد از اختصاص دادن آدرس های IP بر روی روترها در بخض نوبت به ایجاد تانل بین دو روتر میکروتیک میرسه که طبق دستورات زیر انجام میدهیم.

MikroTik-1

[itpro@MikroTik-1] > interface gre
[itpro@MikroTik-1] /interface gre> add remote-address=200.20.20.2

بعد از ایجاد تانل باید یک IP آدرس بر روی اینترفیس Tunnel ایجاد شده طبق تصویر سناریو اضافه بکینم.

[itpro@MikroTik-1] > ip address add address=192.168.1.1/30 interface=gre-tunnel1

به صورت گرافیکی :

5

6

MikroTik-2

ایجاد tunnel :

[itpro@MikroTik-2] > interface gre
[itpro@MikroTik-2] /interface gre> add remote-address=100.10.10.2

اختصاص IP بر روی اینترفیس tunnel :

[itpro@MikroTik-2] > ip address add address=192.168.1.2/30 interface=gre-tunnel1

به صورت گرافیکی :

6

7

بعد از اینکه tunnel بین دو روتر برقرار شد حالا باید به روتر بگیم که برای دسترسی به شبکه های داخلی از تانل استفاده بکنه که این رو با نوشتن یک Static route در روترها طبق دستورات زیر انجام می دهیم.

MikroTik-1

[itpro@MikroTik-1] > ip routes add das-address=172.16.50.1/32 gateway=192.168.1.1

MikroTik-2

[itpro@MikroTik-2] > ip routes add das-address=172.16.30.1/32 gateway=192.168.1.2

بعد از نوشتن دو خط دستور بالا حالا اگر از یکی از روترها ping شبکه داخلی مقابل رو بگیریم برقرار بودن ارتباط ما از طریق Tunnel را نشان خواهد داد.

[itpro@MikroTik-1] > ping 172.16.50.1
HOST                                     SIZE TTL TIME  STATUS
172.50.0.1                                    56 255 64ms
172.50.0.1                                    56 255 61ms
172.50.0.1                                    56 255 69ms
172.50.0.1                                    56 255 54ms

موفق و ITPro باشید.

نویسنده : بهزاد حسن زاده

منبع : جزیره میکروتیک وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی می باشد.

#مرجع_آموزش_میکروتیک_در_ایران #دوره_آموزشی_میکروتیک #آموزش_راه_اندازی_تانل_gre_میکروتیک #تفاوت_ipsec_tunnel_و_gre_tunnel #ارتباط_شبکه_ها_با_تانل_میکروتیک #آموزش_میکروتیک #تانل_gre_میکروتیک #ارتباط_دو_شبکه_با_تانل_میکروتیک #راه_اندازی_gre_tunnel_در_میکروتیک #آموزش_راه_اندازی_gre_در_روتر_سیسکو
3 نظر
محمد جواد صبری

خیلی خوب بهزاد جان انشالله همیشه موفق باشی

بهزاد حسن زاده

ممنون دوست عزیز

انشاالله تو هم همیشه موفق و سر بلند باشی

مهران ساعدی

بهتر نیست به روتر یک بگیم برای اینکه بره به 172.16.50.1 از 192.168.1.2 عبور کنه فکر میکنم روت اینطور بهتر عمل کنه

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره پاییزه می تونی امروز ارزونتر از فردا خرید کنی ....