در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

آموزش راه اندازی RIP بین میکروتیک و سیسکو

با سلام خدمت دوستان و ITPro های عزیز ...در ادامه آموزش قبلی که در مورد پروتکل روتینگ RIP بود و در آن آموزش نحوه عملکرد و کارایی پروتکل RIP را یاد گرفیتم و نحوه پیاده سازی ان بر روی روتر میکروتیک خدمت شما دوستان آموزش دادم. در این سناریو هم که پیاده سازی پروتکل RIP بر روی روترهای میکروتیک و سیسکو جهت تکمیل کردن گفته ها و استفاده از دستورات برای پیکربندی RIP روی میکروتیک خدمت شما کاربران عزیز طراحی کرده ام. که سناریو ما به شکل زیر می باشد:

1

در این سناریو یک روتر مرکزی سیسکو داریم که ارتباط دهنده سه شبکه مختلف می باشد. در هر طرف این روتر مرکزی یک روتر میکروتیک وجود دارد که با استفاده از پورت های Ethernet با هم به صورت back-to-back ارتباط دارند. هر کدام از روترهای میکروتیک از سمت ether2 خودشان با یک شبکه Local که در تصویر هم مشخص هست ارتباط دارند. بعد از شرح سناریو نحوه پیکربندی ادرس IP و پروتکل RIP رو بر روی این روترها به صورت جدا گانه در ادامه خواهیم داشت.

اختصاص دادن آدرس IP بر روی اترنت های روتر میکروتیک و سیسکو

جهت ست کردن IP Address بر روی سه اترنت روتر سیسکو از دستورات زیر در محیط CLI این روتر استفاده می شود:

R1 :

R1(config)#interface ethernet 1/1
R1(config-if)#ip address 192.168.11.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface ethernet 1/2
R1(config-if)#ip address 192.168.12.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface ethernet 1/3
R1(config-if)#ip address 192.168.13.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

و برای ست کردن IP ادرس بر روی اترنت های روتر میکروتیک در محیط Terminal هر روتر از دستورات زیر استفاده میکنیم:

MikroTik-1 :

[itpro@MikroTik-1] > ip address add address=192.168.11.2/30 interface=ether1
[itpro@MikroTik-1] > ip address add address=172.30.0.1/32 interface=ether2

MikroTik-2 :

[itpro@MikroTik-2] > ip address add address=192.168.12.2/30 interface=ether1
[itpro@MikroTik-2] > ip address add address=172.40.0.1/32 interface=ether2

MikroTik-3 :

[itpro@MikroTik-3] > ip address add address=192.168.13.2/30 interface=ether1
[itpro@MikroTik-3] > ip address add address=172.50.0.1/32 interface=ether2

بعد از اتمام اختصاص دادن ادرس های IP بر روی روترها در ادامه نحوه پیکربندی RIP رو خواهیم داشت.

پیکربندی پروتکل RIP بر روی روترهای میکروتیک و سیسکو جهت مسیریابی

جهت فعال کردن و معرفی مسیرهای موجود در شبکه در پروتکل RIP و بر روی روتر سیسکو وارد محیط CLI این روتر شده و در محیط Global از دستورات زیر استفاده می نماییم:

R1 :

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 192.168.11.0
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.12.0
R1(config-router)#exit
R1(config)#

بعد از فعال شدن RIP بر روی روتر سیسکو وارد Terminal روترهای میکروتیک جهت فعال کردن و معرفی مسیرها جهت مسیریابی شده و پروتکل RIP را با استفاده از دستورات زیر فعال میکنیم:

MikroTik-1 :

[itpro@MikroTik-1] > routing rip
[itpro@MikroTik-1] /routing rip> interface 
[itpro@MikroTik-1] /routing rip interface>add interface=ether1
[itpro@MikroTik-1] /routing rip interface>add interface=ether2
[itpro@MikroTik-1] /routing rip>network
[itpro@MikroTik-1] /routing rip network>add network=192.168.11.0/30
[itpro@MikroTik-1] /routing rip network>add network=172.30.0.1/32
[itpro@MikroTik-1] /routing rip>neighbor
[itpro@MikroTik-1] /routing rip neighbor>add address=192.168.11.1

MikroTik-2 :

[itpro@MikroTik-2] > routing rip
[itpro@MikroTik-2] /routing rip> interface 
[itpro@MikroTik-2] /routing rip interface>add interface=ether1
[itpro@MikroTik-2] /routing rip interface>add interface=ether2
[itpro@MikroTik-2] /routing rip>network
[itpro@MikroTik-2] /routing rip network>add network=192.168.12.0/30
[itpro@MikroTik-2] /routing rip network>add network=172.40.0.1/32
[itpro@MikroTik-2] /routing rip>neighbor
[itpro@MikroTik-2] /routing rip neighbor>add address=192.168.12.1

MikroTik-3 :

[itpro@MikroTik-3] > routing rip
[itpro@MikroTik-3] /routing rip> interface 
[itpro@MikroTik-3] /routing rip interface>add interface=ether1
[itpro@MikroTik-3] /routing rip interface>add interface=ether2
[itpro@MikroTik-3] /routing rip>network
[itpro@MikroTik-3] /routing rip network>add network=192.168.13.0/30
[itpro@MikroTik-3] /routing rip network>add network=172.50.0.1/32
[itpro@MikroTik-3] /routing rip>neighbor
[itpro@MikroTik-3] /routing rip neighbor>add address=192.168.13.1

خب بعد از اتمام انجام دستورات بالا بر روی هر 4 روتر سناریو جهت اطمبنان از صحت کار خود وارد روتر 1 میکروتیک می شوم و یکی از شبکه های داخلی یکی از روترهای را ping کرده و نتیجه این دستور را با هم مشاهده میکنیم :

[itpro@MikroTik-1] > ping 172.50.0.1
HOST                                     SIZE TTL TIME  STATUS
172.50.0.1                                    56 255 64ms
172.50.0.1                                    56 255 61ms
172.50.0.1                                    56 255 69ms
172.50.0.1                                    56 255 54ms

همانطور که می بینید ارتباط ما با شبکه مقصد برقرار هست و این نشان می دهد که همه عملیات ما درست بود و مسیریابی بین این 3 شبکه به درستی انجام میگیرد.

موفق و ITPro باشد.

نویسنده : بهزاد حسن زاده

منبع : جزیره میکروتیک وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی می باشد.

#routing_بین_سیسکو_و_میکروتیک #آموزش_گام_به_گام_میکروتیک #پروتکل_rip_در_سیسکو #ارتباط_3_شبکه_با_rip_در_میکروتیک #دستورات_فعال_کردن_rip_میکروتیک #روتینگ_بین_mikrotik_و_cisco #سناریو_rip_در_میکروتیک #مرجع_یادگیری_میکروتیک_در_ایران #راه_اندازی_routing_بین_سیسکو_و_میکروتیک
0 نظر

هیچ نظری ارسال نشده است! اولین نظر برای این مطلب را شما ارسال کنید...

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره پاییزه می تونی امروز ارزونتر از فردا خرید کنی ....