در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

تقسیم پهنای باند عادلانه و مساوی برای کاربران مثل آب خوردن

با توجه به اینکه امروز شبکه ها رو به افزایش هستند نیاز به کنترل پهنای باند هم امری ضروری و مهم است از این رو برای شما عزیزان اموزش تقسیم پهنای باند مثل آب خورذن رو آماده می کنم.خوب بریم سر کارمون , برای این کار مانیاز داریم که رو بسته های که از روتر خارج می شن mangle ایجاد کنیم که به دو دسته زیر تقسیم می شوند :

  1. پکت های که به سمت اینترنت می روند (upload)
  2. پکت های که به سمت کاربر می روند (download)

برای این کار با من محمد جواد صبری همراه باشید. برای ایجاد mangle مراحل زیر را طی نمایید

1.به منوی IP و Route بروید.

1

2.به سربرگ mangle رفته و روی add کلیک کنید.

2

3.در این مرحل ترافیک که از سمت کلاینت به روتر وارد می شود را می خواهیم مدیریت کنیم (Upload) کلاینت ها به اینترفیس Wlan1 متصل هستند.

3

4.حال در سربرگ action مقدار را روی mark packet قرار می دهیدم و در قسمت New packet mark مقدار Upload را تایپ می کنیم.

4

5.در این مرحل ترافیک که از سمت اینترنت به روتر وارد می شود را می خواهیم مدیریت کنیم (Download) کلاینت ها به اینترفیس Ether1 متصل هستند.

5

6.حال در سربرگ action مقدار را روی mark packet قرار می دهیدم و در قسمت New packet mark مقدار Download را تایپ می کنیم.

6

7.حال به منوی Queue می رویم.

7

8.حال به سربرگ Queue Type رفته و روی add کلیک می کنیم.

8

9.در این قسمت یک نام برای PCQ انتخاب می کنیم و kind را روی pcq و rate را روی سرعت مورد نظر جهت آپلود قرار می دهیم مثلا 64k.

تقسیم پهنای باند عادلانه و مساوی برای کاربران مثل آب خوردن

10.در این قسمت یک نام برای PCQ انتخاب می کنیم و kind را روی pcq و rate را روی سرعت مورد نظر جهت دانلود قرار می دهیم مثلا 256k.

10

11.سپس به منوی Queue Tree میرویم و روی add کلیک می کنیم.

11

12.سپس جهت تعریف Queue Tree جهت دانلود Packet Mark را روی Mangle که برای دانلود ساختید قرار دهید و Queue Type رو هم PCQ که برای دانلود ساختید قرار دهید.

12

13.سپس جهت تعریف Queue Tree جهت آپلود Packet Mark را روی Mangle که برای دانلود ساختید قرار دهید و Queue Type رو هم PCQ که برای آپلود ساختید قرار دهید.

13

14.این هم نتیجه کارما .

14

امبدوارم بهره کافی رو از این آموزش برده باشید

پیروز باشید

نویسنده : محمد جواد صبری

منبع : جزیره میکروتیک وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی است

#مدیریت_پهنای_باند_اینترنت_با_میکروتیک #راه_اندازی_اکانتینگ_در_mikrotik #مدیریت_ترافیک_اینترنت_با_میکروتیک #مدیریت_اینترنت_با_روتر_mikrotik #اکانتینگ_در_میکروتیک #تنظیمات_user_manager_میکروتیک #راه_اندازی_اکانتینگ_در_میکروتیک #مدیریت_پهنای_باند_در_میکروتیک
28 نظر
 نیما شایق

با تشکر از مطلب آموزنده شما.

و یک نکته که من میتونم اضافه کنم اینکه اگر pcq rate صفر بشه اون وقت حداکثر پهنای باند قابل دسترس بین کاربران تقسیم میشه. مثلا اگر یک کاربر متصل باشه کل maxrate رو به خودش اختصاص میده و اگر دو کاربر متصل بشن نصف maxrate رو به خودشون اختصاص میدن و... .

همچنان که در شکل های زیر نشون داده شده:

http://wiki.mikrotik.com/wiki/File:PCQ3.png

http://wiki.mikrotik.com/wiki/File:PCQ4.png

 نیما شایق

ممنون از مطلب خوبتون.

سوالی که من دارم ازتون اینه که شما قصد دارین 256 کیلوبایت رو بین کاربرانتون تقسیم کنید یا اینکه به هر کاربر 256 کیلوبایت پهنای باند بدید.

چون ظاهرا بنا بر اونچه سایت میکروتیک گفته pcqrate مقداریه که بین کاربران تقسیم میشه و مثلا در مورد شما 256 کیلوبایت باید بین کاربران تقسیم بشه و اگر دو کاربر داشته باشیم هرکدوم 128 کیلو و به همین شکل تا هر تعداد کاربری این میزان بینشون تقسیم میشه.

مجتبی کریمی

امکانش هست یک رینج ای پی یا مک ادرس رو معاف کرد از این پالسی؟

برای مثال سرور WSUS در شبکه هست که نیاز به پهنای باند بالا داره. چی کار باید کرد؟

 نیما شایق

@MK94 : این دو روش رو امتحان کنید :

1-در mangle کردن ترافیک آپلود، source address و در منگل دانلود، destination address رو آدرس ip سرور به همراه یک علامت ! در ابتدای اون بزنید.(یعنی تمام آدرس ها بجز این آدرس)

2-به سرور یک آدرس static بدید مثلا 192.168.1.128 سپس در mangle به جای انتخاب یک اینترفیس به عنوان ورودی یا خروجی از یک رنج ip استفاده کنید مثلا رنج 192.168.1.0/25 که شامل آدرس سرور شما نمیشه.

محمد جواد صبری

سلام خدمت دوستان

سوال اول این بود که ایا به هر کاربر 256 کیلوبیت میده یا 256 کیلوبیت رو تقسیم می کنه

روش PCQ کل پهنای باند رو به طور عادلانه و با توجه به اولویت بین کاربران تقسیم می کند

سوال دوم این بود که ایا می توان یک رنج خاص را از این محدودیت معاف کرد. باید بگم در این صورت به جای اینترفیس رنج ایپی را محدود می کنیم و سیستم های که نمی خوایم محدودیت داشته باشند را خارج از محدودی ایپی قرار می دهیم

باز هم اگه سوال هست یا نیاز به توضیح بیشتر درخدمت هستم

باتشکر از توجه شما عزیزان

علی شاهی

سلام ..

آقا من اینکار می خوام انجام بدم ولی روتر ندارم می خوام رو ویندوز سرور ترافیک روزانه و محدود برای کاربرای که تو DC هستن ...برای وین سرور هم یه آموزش ارائه بدید ..تشکر

1.به منوی IP و Route بروید. (این نرم افزار خاصی هستش یا تنظیمات روتره)

محمد جواد صبری

سلام

شما می توانید RouterOS را به صورت مجازی نصب کنید و همین تنظیمات را انجام دهید

shahabi

باتشکر از مطالب آموزندتون..

واقعالاییییییییییییییک

Gelareh Soluki

سلام

این مدیریت پهنای باندی که انجام دادی

چرا هیچ src-address رو set نکردین؟ (صف هارو اول تشکیل دادید آره ؟)

و اینکه در قسمت firewall چرا chain روی prerouting هستش ؟

pcq همینه؟

و اینکه priority روی همون عدد 8 باشه؟(ی دونه queue دارید؟)

Gelareh Soluki

اگر چندتا رنج روی lan ما بود باید چیکار کرد؟

محمد جواد صبری

سلام با روش که من در اینجا ذکر کردم چون با Packet mark کار شده اهمیتی نداره همه ایپی ها شامل این محدودیت می شوند

Gelareh Soluki

خب اگه بخواییم اون آی پی هایی که خودمون میخوایم رو mange کنیم

چطوری میشه؟

Gelareh Soluki

منظورم اینه باید queue براش set کرد؟

محمد جواد صبری

سوالتون طبق قوانین در انجمن مطرح کنید تا پاسخ گو باشید

موفق باشید

Gelareh Soluki

ممنون از آموزشتون

اینو به توضیحتون اضافه میکنم که PCQ به اینصورت هست که به ازای هر تعداد کاربر صف تشکیل میده و هرکاربری که میخواد از اینترنت استفاده کنه صف براش تشکیل میشه و پهنای باند به طور مساوی تقسیم میشه

و اگر هم تعداد کاربرا کم بشن باز همون مقدار کم میکنه تعداد صف ها رو و اگر کاربری از دانلود منجر (تعداد کانکشن بیشتری باز کنه) استفاده کنه و بخواد از کل پهنای باند اسفاده کنه اینطور نیست و فقط سرعت صف خودش کم میشه

و نمیتونه از پهنای باند بقیه استفاده کنه

ebrahim1110

سلام

چرا ether کلاینت ها در شماره 3 و پنج فرق داره؟

مگر کلاینتها دانلود و آپلودشون به یه پورت وصل نیست؟

Gelareh Soluki

دوست عزیز شما این سناریو رو به اینصورت در نظر بگیرید

که ترافیک ورودی از Wlan وارد میشه برای آپلود

و ترافیک ورودی از سمت اینترنت به داخل برای دانلود

اینترفیسی هست که مودم بهش وصل هست و اینترنت رو میده به میکروتیک

ebrahim1110

سلام ممنون ولی باز هم متوجه نشدم.

من میخوام برای شبکه خودم از این سناریو استفاده کنم تا اینترنت 2 مگ برای شبکم به صورت مساوی تقسیم شه.

سناریو:

1- مودم از به پورت یک شبکه وصله و میکروتیک با ppoe از طریق این مودم اینترنت میگیره

2- بقیه سیستم ها از طریق دو پورت شماره 2 و 3 و همچنین وایفای میکروتیک به شبکه وصلن.

حالا این مطلب شمارو چطور باید پیاده کنم؟

Gelareh Soluki

سلام

مودم شما نوع کانکشنش pppoe هس؟

اگر که اینطور باشه و مودم به ی اینترفیس روتر میکروتیک وصل هست

دیگه نیازی نیست که میکروتیک هم خودش pppoe بزنه! فقط ی default Route بزن سمت مودمت که میکروتیکت اینترنت داشته باشه!

مگر اینکه کلاینت های شبکه ی lan رو بخواید pppoe بزنن که هرکسی نتونه اینترنت داشته باشه و شبکه ی lan رو nat کنید که بشه بهش اینترنت داد.

3 تا رنج شبکه دارید ؟

ebrahim1110

سلام

مشکلی با کانکشن ppoe ندارم.

عمده مشکلم برای ایجاد تنظیمات pcq هست. برای اینکه اینترنت به صورت هوشمند مساوی بین کاربران تقسیم بشه. چون تعداد کاربرا متغیره.

یک پورت به مودم وصله برای کانکشن ppoe

یک پورت به سوییچ وصله و یک رنج آی پی داره

یک پورت به بخش کتابخانه وصله که روش هات اسپات نصبه.

و یک wlan هم دارم.

محمد جواد صبری

سلام

سوالتون در در انجمن با ذکر تصویر بپرسید تا پاسخ دهیم

ebrahim1110

سلام

سوالم در مورد آموزش این مطلبه.

عرضم اینه چرا ether کلاینت ها در شماره 3 و پنج فرق داره؟

توضیحی که شما دادید متوجه نشدم.

Gelareh Soluki

آقای ابراهیم 2 تا pcq باید تعریف کنی

واسه ی شبکه ای lan ی که روی wlan هست

و اون دیگری اینترفیست که به کتابخونه وصل هس

اون مشکلی هم که میگی اگر ی سرچ کنی میفهمی که شبکه ی lan هم آپلود میکنن و هم دانلود

و برای اینکه روشون صف از نوع pcq ایجاد کنی باید بدونی که از چه اینترفیسی اینترنت میاد سمتشون برای دانلود (همون اینترفیسی که به مودم وصل هس)

و از چه سمتی کلاینت های lan درخواستشون رو به سمت اینترنت میفرستن

همین

در شماره ی 3 و 5 هم همینه

شما خودت ی سناریو رو در نظر بگیر دوست عزیز

همیشه اینترنت رو از ی اینترفیس میگیری و از ی اینترفیس دیگه میدی به شبکه ی lan

هردوتا کارو که روی ی اینترفیس انجام نمیدی دوستم

علی شاهی

سلام -چطور می تونیم محدودیت حجمی اعمال کنیم . مثلا یورز فلان روزانه 100 مگ بیشتر اینترنت نداشته باشه؟؟؟

مصطفی  آهنگری

سلام و خسته نباشید.

واقعا آموزش عالی و کاربردی بود.

فقط سوالی که دارم اینه که من این روش رو بر روی 2 روتر میکروتیک 951 اعمال کردم. روی یکی از اونها خوب جواب داد ولی روی دومی تقریبا سرعت همه کاربران رو به صفر رسوند. حتی زمانی که فقط یک کاربر به روتر متصل میشد هم هیچ پهنای باندی نداشت. مطمئن هم هستم تنظیمات دقیقا مشابه روتر اول بود.

آیا ممکنه مشکل از روتر ما باشه؟ یا مثلا نیاز به آپدیت داشته باشه؟

morteza pourghassem

سلام و تشکر از آموزش عالی که گذاشتین

سوالی که داشتم اینه که فرض کنید پهنای باند 10مگ دارم - میخوام پهنا نسبت به تعداد کاربران وصل شده تقسیم بشه

مثلا

1 کاربر وصل میباشد ،پهنای باند=10 مگ برای کاربر

2کاربر وصل میباشد ،پهنای باند=5 مگ برای هر کاربر

10 کاربر وصل میباشد ،پهنای باند=1مگ برای هر کاربر

و ...

sanup2006

چگونه با این روش یک رنج آی پی ر. محدود کنیم ؟ میشه بیشتر توضیح بدید که یعنی چی به جای اینترفیس رنج ای پی قرار بدیم ؟

با این روش همه ی اون کاربرها سرعت محدود شده رو میگیرند ؟یعنی اگر 2 مگ بذاریم همه 2 مگ پهنای باند دارن ؟

محمدحسن ذکاوت

/ip firewall mangle

add action=mark-packet chain=prerouting in-interface=ether3 new-packet-mark=upload

add action=mark-packet chain=postrouting new-packet-mark=download out-interface=ether3

سپاس از تولید محتوای بی نظیر

فکر می کنم با این دوتا منگل پکت های خیلی قشنگتر مچ می کنند به عنوان پیشنهاد تست کردم جواب داد

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره تابستانه می تونی امروز ارزونتر از فردا خرید کنی ....