آموزش ارسال لاگهای میکروتیک به ایمیل به زبان ساده

چگونه فایل های لاگ میکروتیک را به ایمیل خودمان ارسال کنیم؟ با سلام ، شاید خیلی از شماها میخواستید لاگ های میکروتیک رو جاییی ذخیره کنید اما یا میکروتیک فضا نداشته یا سرور مخصوص syslog نداشتید ، نگران نباشید خیلی راحت با این اسکریپت میتونید لاگ هارو هم به ایمیل خودتون ارسال کنید ، فقط باید طبق آموزش قبلی من که ارسال بکاپ به ایمیل بود سرویس ایمیل رو در میکروتیک تنظیم کنید.این کد اسکریپت ، نحوه کار اسکریپت هم مثل اسکریپت قبلی ارسال ایمیل هست

دوره های شبکه، برنامه نویسی، مجازی سازی، امنیت، نفوذ و ... با برترین های ایران
:log info "Mikrotik log E-mail start  . . . "
/log print file=log
:log info "Makeing LOG file process pausing for 10s so it complete creating log file"
:delay 10s
:log info "Start Sending log File via Email using GMAIL SMTP  . . ."
/ tool e-mail send to=youremail@email subject=([/system clock get date].\ " ".\ [/system clock get time] . \ " MikroTik log file") body="MikroTik email log"  file=log
:log info ("log file e-mail status:  ".\ [/tool e-mail get last-status])
:delay 40s
:if ([/tool e-mail get last-status] = "failed") do={log error "Can`t send E-mail cheak it...";log error "Restart E-mail log file";[/system script run system_log_email ]} else={:log warning ("log e-mail status:  ".\ [/tool e-mail get last-status]);:log info "log e-mail Finished";:log info "Deleting log File. All Done.";/file remove log;}

youremail@emai رو باید بر اساس ایمیل مقصد خودتون تنظیم کنید


فربد رستم صولت
فربد رستم صولت

فربد رستم صولت شبکه های مایکروسافتی ، مجازی سازی ، هاستینگ ، ویپ ، میکروتیک ، برنامه نویس زبان G ،برنامه نویس سخت افزار های صنعتی و غیر صنعتی طراح و سازنده و برنامه نویس روبات های صنعتی و غیر صنعتی ، پرنده و زمینی و همچنین علاقمند به ارتباط تمام اشیا به یکدیگر هستم همون iot. بدلیل تازه کار بودن سوابق زیادی ندارم از کلاس چهارم ابتدایی وارد حوضه IT شدم و تا الان این ادامه داشته و خواهد داشت.

06 مهر 1396 این مطلب را ارسال کرده

نظرات