تا %60 تخفیف خرید برای 2 نفر با صدور مدرک فقط تا
00 00 00

آموزش راه اندازی MPLS در میکروتیک ( Mikrotik )

امیرحسین تنگسیری نژاد
امیرحسین تنگسیری نژاد
1 پسند
99 بازدید
0 نظر
19 روز قبل

پروتکل MPLS که امروزه از محبوبیت بسیار زیادی برخوردار میباشد توانایی مسیریابی بسته هارا براساس روشی نوین تر به ما ارائه میدهد و مارا از IP Routing های قدیمی بی نیاز میکند و مسیریابی بسته های مارا با سرعت بالاتری انجام میدهد. اما همه این مباحث به این موضوع بدل نمیشود که بابت افزایش فقط چند میلی ثانیه سرعت مسیریابی و همگرایی شبکه بیایند یک استاندارد و پروتکل جدیدی را ارائه بدهند از این بابت پروتکل MPLS دارای ویژگی های بسیار زیادی میباشد که امروزه جوابگو خیلی از محیط های Service Provider میباشد.

در این مقاله تمرکز ما بر این موضوع است که نحوه پیکربندی و راه اندازی یک شبکه MPLS Core را از طریق روتر های شرکت Mikrotik را فرا بگیریم اما شاید هم سوال شود که آیا واقعا تجهیزات و روتر های شرکت Mikrotik توانایی راه اندازی MPLS را دارند؟ باید بگوییم بله، زیرا برای راه اندازی بستر MPLS Core اولین نیاز ما پروتکل LDP میباشد که یک ‌پروتکل آزاد استاندارد میباشد و در Mikrotik نیز وجود دارد.
برای آشنایی بیشتر با مفاهیم MPLS و اجزا آن به ویدیو های دوره آموزشی MPLS مراجعه کنید.

نحوه پیکربندی MPLS در روتر های Mikrotik

برای راه اندازی شبکه MPLS ما سناریو زیر را در نظر گرفته اییم که متشکل از سه روتر روتر Provider و سه روتر Provider Edge میباشد.

آموزش راه اندازی MPLS در میکروتیک ( Mikrotik )

ابتدا در تمامی دیوایس هایمان یک رابط Loopback ایجاد میکنیم به این دلیل که فرقی نمیکند در بین دو روتر چند لینک وجود داشته باشد زیرا فقط یک LDP Session ایجاد می‌شود و از این بابت از آدرس رابط Loopback نیز میتوانیم برای LSR ID و Transport Address خود استفاده کنیم.

P1

/interface bridge add name=lobridge
/ip address add address=10.255.255.1/32 interface=lobridge

P2

/interface bridge add name=lobridge
/ip address add address=10.255.255.2/32 interface=lobridge

P3

/interface bridge add name=lobridge
/ip address add address=10.255.255.3/32 interface=lobridge

PE1

/interface bridge add name=lobridge
/ip address add address=10.255.255.4/32 interface=lobridge

PE2

/interface bridge add name=lobridge
/ip address add address=10.255.255.5/32 interface=lobridge

PE3

/interface bridge add name=lobridge
/ip address add address=10.255.255.6/32 interface=lobridge

حال به سراغ پیکربندی آدرس های IP رابط های Ethernet دیوایس هایمان میرویم

P1

/ip address 
add address=10.0.255.1/30 interface=ether1 
add address=10.0.255.5/30 interface=ether2
add address=10.1.0.254/24 interface=ether3

P2

/ip address 
add address=10.0.255.6/30 interface=ether1 
add address=10.0.255.9/30 interface=ether2
add address=10.2.0.254/24 interface=ether3

P3

/ip address 
add address=10.0.255.10/30 interface=ether1
add address=10.0.255.2/30 interface=ether2
add address=10.3.0.254/24 interface=ether3

PE1

/ip address 
add address=10.1.0.1/24 interface=ether1

PE2

/ip address 
add address=10.2.0.1/24 interface=ether1

PE3

/ip address 
add address=10.3.0.1/24 interface=ether1

در این بخش میبایست یک Dynamic Routing راه اندازی کنیم که شبکه مان به صورت کامل Full Reachable باشد که LDP توانایی این را پیدا کند در شبکه ما شروع به راه اندازی شبکه MPLS Core کند

P1

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.1 numbers=default
/routing ospf network 
add area=backbone network=10.0.255.0/30 
add area=backbone network=10.0.255.4/30 
add area=backbone network=10.1.0.0/24 

P2

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.2 numbers=default
/routing ospf network 
add area=backbone network=10.0.255.8/30 
add area=backbone network=10.0.255.4/30 
add area=backbone network=10.2.0.0/24 

P3

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.3 numbers=default
/routing ospf network 
add area=backbone network=10.0.255.0/30 
add area=backbone network=10.0.255.8/30 
add area=backbone network=10.3.0.0/24 

PE1

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.4 numbers=default
/routing ospf network 
add area=backbone network=10.1.0.0/24 

PE2

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.5 numbers=default
/routing ospf network 
add area=backbone network=10.2.0.0/24 

PE3

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.6 numbers=default
/routing ospf network 
add area=backbone network=10.3.0.0/24 

و در آخر نیز به سراغ رابط های Ethernet مورد نظرمان که قرار است در شبکه MPLA Core قرار داشته باشند میرویم و LDP را بر روی آنها فعال سازی میکنیم

P1

/mpls ldp 
set enabled=yes lsr-id=10.255.255.1 transport-address=10.255.255.1
/mpls ldp interface 
add interface=ether1
add interface=ether2
add interface=ether3

P2

/mpls ldp 
set enabled=yes lsr-id=10.255.255.2 transport-address=10.255.255.2
/mpls ldp interface 
add interface=ether1
add interface=ether2
add interface=ether3

P3

/mpls ldp 
set enabled=yes lsr-id=10.255.255.3 transport-address=10.255.255.3
/mpls ldp interface 
add interface=ether1
add interface=ether2
add interface=ether3

PE1

/mpls ldp 
set enabled=yes lsr-id=10.255.255.4 transport-address=10.255.255.4
/mpls ldp interface 
add interface=ether1

PE2

/mpls ldp 
set enabled=yes lsr-id=10.255.255.5 transport-address=10.255.255.5
/mpls ldp interface 
add interface=ether1

PE3

/mpls ldp 
set enabled=yes lsr-id=10.255.255.6 transport-address=10.255.255.6
/mpls ldp interface 
add interface=ether1

حال در قسمت LDP Neighbor در تب MPLS میبایست به شما همسایه های LDP تان را نشان بدهد.

آموزش راه اندازی MPLS در میکروتیک ( Mikrotik )

همچنین از دستور زیر هم میتوانید استفاده کنید:

mpls ldp neighbor print 

موفق باشید

نظر شما
برای ارسال نظر باید وارد شوید.
0 نظر

هیچ نظری ارسال نشده است! اولین نظر برای این مطلب را شما ارسال کنید...