تا %60 تخفیف خرید برای 5 نفر با صدور مدرک فقط تا
00 00 00

آموزش ایجاد محدودیت سرعت اینترنت در میکروتیک و تعیین اولویت Queue

مجتبی شمس نجاتی
مجتبی شمس نجاتی
4 پسند
985 بازدید
4 نظر
24 ماه قبل

چگونه در Mikrotik محدودیت سرعت اینترنت ایجاد کنیم؟ چگونه اولویت صف ها یا Queue ها را تعیین کنیم؟ برای محدودیت سرعت کاربران در میکروتیک از Queue ها استفاده می شود. وقتی در شبکه ای پهنای باند محدود و با توجه به تعداد کاربران امکان پُر شدن وجود داشته باشد، نیاز به اولویت دادن به queue ها بسیار احساس می شود.در این مقاله با یک مثال عملی و کانفیگ خط به خط این مورد را آموزش میدهیم. به تصویر زیر دقت کنید:

وب سایت توسینسو

در این شبکه میکروتیک از طریق پورت اول به اینترنت و از طریق پورت دوم به شبکه داخلی متصل است.آدرس میکروتیک در شبکه داخلی 192.168.1.1 و آدرس کلاینت ها همانطور که در تصویر مشخص است در رنج 192.168.1.0/24 وجود دارد و گیتوی آنها 192.168.1.1 یعنی میکروتیک است.(در این آموزش به تنظیمات DHCP ، Nat و ... در میکروتیک نمیپردازیم و صرفا هدفمان محدودیت سرعت و تعیین اولویت آن است.) فرض میکنیم لینک اینترنت شبکه ، پهنای باند 8mbps دارد. بنابراین یک Queue بعنوان پدر برای سایر Queue ها ایجاد میکنیم با محدودیت کلی 8mbps

/queue simple add max-limit=8M/8M name=Parent-Queue target=192.168.1.0/24

حالا قصد داریم به هرکدام از 3 کلاینت محدودیت سرعت 4mbps بدهیم. بنابراین:

/queue simple
add max-limit=4M/4M name=PC1-Queue parent=Parent-Queue target=192.168.1.11
add max-limit=4M/4M name=PC2-Queue parent=Parent-Queue target=192.168.1.12
add max-limit=4M/4M name=PC2-Queue parent=Parent-Queue target=192.168.1.13

اگر هر سه کلاینت با حداکثر سرعت شروع به دانلود (یا آپلود) کنند، مشخص است برای رسیدن به سرعت 4mbps نیاز به 12mbps پهنای باند داریم در صورتی که پهنای باند اینترنت 8mbps است. بنابراین همان 8mbps بین سه کلاینت تقسیم می شود و هرکدام حدود 2.5mbps سرعت خواهند داشت. حال اگر بخواهیم به PC1 اولویت بیشتری دهیم تا از حداکثر پهنای باند خود استفاده کند باید از خاصیت Priority استفاده کنیم که به معنای اولویت است. Priority میتواند بین عدد 1 تا 8 باشد. 1 بیشترین و 8 کمترین اولویت را دارد و بصورت پیشفرض تمام Queue ها Priority برابر با 8 دارند. بنابراین PC1-Queue را بصورت زیر تغییر میدهیم:

/queue simple set PC1-Queue priority=1/1

بعد از این تغییرات ، در صورتی که هر سه کلاینت قصد استفاده از حداکثر پهنای باند را داشته باشند، به PC1 سرعت 4mbps و به PC2 و PC3 هرکدام 2mbps پهنای باند تخصیص داده می شود.

نظر شما
برای ارسال نظر باید وارد شوید.
4 نظر