در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

نحوه backup گرفتن اتوماتیک میکروتیک-قسمت اول

سلام به دوستان عزیز ITPro ای و علاقه‌مندان به میکروتیک. در این مقاله قصد دارم شما رو با نحوه backup گیری اتوماتیک میکروتیک اشنا کنم.شاید خیلی وقت شما نیاز دارین در یک ساعت خاص از روز یا در ی بازه زمانی از میکروتیک خودتون backup بگیرین ولی به هر دلیلی خودتون حضور ندارین،شما میتونید باانجام یکسری تنظیمات این کار به عهده خود روتر بزارین تا براتون Backup بگیره. مباحثی که میخواییم باهم بررسی کنیم بصورت زیر است:

* 1 E-mail backups

2 Automated central backups

2.1 Introduction

2.2 Router configuration *

2.3 Server configuration

2.4 Creating an FTP script template

2.5 Configuring Windows scheduler

3 Final adjustments

در قسمت اول این مقاله 4 مورد اول را بررسی میکنیم

______________________________

E-mail backups

یکی از ساده ترین روش ها backup گیری اتوماتیک استفاده از سیستم ایمیل ساخته شده در میکروتیک است. تنظیم آن متشکل از چند دستور و با بهره گیری از زمانبندی برای اجرای اسکریپت ایمیل در هر زمان داده شده است. قبل از ادامه بر اجرای اسکریپت ایمیل، لازم که مطمئن باشید سیستم پست الکترونیکی برای ارسال ایمیل به درستی پیکربندی شده.با تایپ دستور زیردر کنسول MT شما میتوانید این کار را انجام دهید

/tool e-mail print

شما باید ی خروجی شبیه خروجی زیر دریافت کنید

server: 192.168.0.1

from: mikrotikbackup@yourhost.com

که "192.168.0.1" آدرس SMTPسرور شما و mikrottikbackup@yourhost.com ایملیل آدرسی هست که MTبرای شناسایی خودش وقتی backup ها را ارسال میکند استفاده خواهد کرد.اگر شما همچنین خروجی مشاهده نکردین شما باید تنظیمات مربوط به کانفیگ e-mail را با استفاده از دستور زیر انجام بدهید:

/tool e-mail

set server=192.168.0.1 from=mikrotikbackup@yourhost.com

در این قسمت شما باید اسکریپت های لازم برای ارسال ایمیل وارد کنید.طبق دستور زیر:

tool e-mail send to="youremail@yourhost.com" subject=([system identity get name]." backup") file=email.backup;

:log info "Backup e-mail sent."; {

بجای youremail@yourhost.com شما باید ایمیل مربوط به دریافت کننده را وارد کنید.اگر شما تصمیم داشته باشید از چند ایمیل ادرس استفاده کنید ،اجرا کنید دستورات زیر:

/system script

add name="e-mail-backup" source={/system backup save name=email;

tool e-mail send to="youremail1@yourhost.com" subject=([system identity get name]." backup") file=email.backup;

tool e-mail send to="youremail2@yourhost.com" subject=([system identity get name]." backup") file=email.backup;

tool e-mail send to="youremail3@yourhost.com" subject=([system identity get name]." Backup") file=email.backup;

:log info "Backup e-mail sent."; }

آخرین مرحله این است که config زمانبندی برای اجرای اسکریپت بالا در یک بازه زمانی است .اجرای دستور زیر باعث میشود هر روز اسکریپت اجرا شود:

/system scheduler

add comment="" disabled=no interval=1d name="e-mail-backup" \

on-event=e-mail-backup start-date=jan011970 start-time=00:00:00

وقتی انجام می شود، شما می توانید تنظیمات خود را در Winboxبررسی کنید، وباید به چیزی شبیه شکل زیر برسید:

نحوه backup گرفتن اتوماتیک میکروتیک-قسمت اول

نحوه backup گرفتن اتوماتیک میکروتیک-قسمت اول

Router configuration

اول از همه، ما باید تمام روترهایی رو که نیاز به طور مکرر backup بگیرن رو کانفیگ کنیم. (در این مثال، من میخوام هر روز این کار انجام بده) برای این کار، ما این دستور در هر روتر را اجرا کنیم:

/system scheduler

add name="backup" on-event="system backup save name=today.backup" \

start-date=jan011970 start-time=00:00:00 interval=10h comment="" \

disabled=no

دستور بالا خیلی ساده است،یک فایل Backupمیکروتیک به نام "today.backup" که هر 10 ساعت انجام خواهد شد را ایجاد میکند. میتونیم به فایل های Backup توسط سرور اصلی ما از طریق FTP دسترسی داشته باشیم . با اجرای دستور زیر ما مطمئن خواهیم شد که همه چیز به درستی کار میکند:

/system backup save name=today.backup

خب بعد از این مرحله فایل backup باید ایجاد شده باشد. برای اطمینان به لیست فایل ها مراجع میکنم:

نحوه backup گرفتن اتوماتیک میکروتیک-قسمت اول

در قسمت روتر تنظیمات تقریبا کامل است، اما باید مطمئن بشیم که دسترسی به FTP موجود است:

/ip service print

When the command is executed, the following output (or similar) should appear:

Flags: X - disabled, I - invalid

# NAME PORT ADDRESS CERTIFICATE

0 telnet 23 0.0.0.0/0

1 ftp 21 0.0.0.0/0

2 www 80 0.0.0.0/0

3 ssh 22 0.0.0.0/0

4 X www-ssl 443 0.0.0.0/0 none

5 X api 8728 0.0.0.0/0

6 winbox 8291 0.0.0.0/0

اگر هیچ "X" در کنار آیتم FTP در لیست ظاهر شده وجود نداشته باشد یعنی اماده برای انجام ادامه برنامه. توصیه میشود بدلایل امنیتی برای هر روتر بصورت مجزا یک FTP ایجاد کرده :

/user group

add name="ftp" policy=ftp,!local,!telnet,!ssh,!reboot,!read,!write,!policy,!test,!winbox,!password,!web,!sniff

/user

add address=0.0.0.0/0 comment="FTP backup" disabled=no group=ftp name="ftp"

/user

set [find name="ftp"] password="mypass"

منتظر قسمت بعدی باشید.ITPRO ّ باشید.

نویسنده: الهام زاهدی فرد

منبع: جزیره میکروتیک وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی می باشد.

#backup_گیری_خودکار_از_میکروتیک #بکاپ_گیری_از_روتر_میکروتیک #backup_گیری_از_روترهای_میکروتیک #Backup_گیری_از_روتر_سیسکو #backup_گیری_از_روتربورد_میکروتیک #backup_گیری_از_روتر_میکروتیک #backup_گیری_اتوماتیک_از_میکروتیک #بکاپ_گرفتن_از_تنظیمات_روتر_میکروتیک
عنوان
1 نحوه backup گرفتن اتوماتیک میکروتیک-قسمت سوم رایگان
2 نحوه backup گرفتن اتوماتیک میکروتیک-قسمت دوم رایگان
3 نحوه backup گرفتن اتوماتیک میکروتیک-قسمت اول رایگان
زمان و قیمت کل 0″ 0
2 نظر
فرهاد خانلری

تشکر میکنم از شما بابت مطلب کاربردی تون ، فقط مطلب های به هم پیوسته رو ویرایش کنید و در قسمت "گروه مطلب" یک گروه برای مطلب ایجاد کنید در این صورت سیستم به صورت اتوماتیک مطالب رو دسته بندی میکنه و نیازی نیست شما خودتون لینک ها رو قرار بدید.

با تشکر

الهام السادات زاهدی فرد

سلام خواهش میکنم

حتما

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره تابستانه می تونی امروز ارزونتر از فردا خرید کنی ....