الهام السادات زاهدی فرد
هر روز در حستجو علم

آموزش انواع روش های بکاپ گیری از میکروتیک به صورت خودکار

دوره های شبکه، برنامه نویسی، مجازی سازی، امنیت، نفوذ و ... با برترین های ایران

چگونه از Mikrotik بصورت اتوماتیک Backup بگیریم؟ در این مقاله قصد دارم شما رو با نحوه backup گیری اتوماتیک میکروتیک اشنا کنم.شاید خیلی وقت شما نیاز دارین در یک ساعت خاص از روز یا در ی بازه زمانی از میکروتیک خودتون backup بگیرین ولی به هر دلیلی خودتون حضور ندارین،شما میتونید باانجام یکسری تنظیمات این کار به عهده خود روتر بزارین تا براتون Backup بگیره. مباحثی که میخواییم باهم بررسی کنیم بصورت زیر است:

  1. E-mail backups
  2. Automated central backups
  3. Introduction
  4. Router configuration
  5. Server configuration
  6. Creating an FTP script template
  7. Configuring Windows scheduler
  8. Final adjustments

در قسمت اول این مقاله 4 مورد اول را بررسی میکنیم

ارسال Backup میکروتیک در قالب ایمیل

یکی از ساده ترین روش ها backup گیری اتوماتیک استفاده از سیستم ایمیل ساخته شده در میکروتیک است. تنظیم آن متشکل از چند دستور و با بهره گیری از زمانبندی برای اجرای اسکریپت ایمیل در هر زمان داده شده است. قبل از ادامه بر اجرای اسکریپت ایمیل، لازم که مطمئن باشید سیستم پست الکترونیکی برای ارسال ایمیل به درستی پیکربندی شده.با تایپ دستور زیردر کنسول MT شما میتوانید این کار را انجام دهید

/tool e-mail print

شما باید ی خروجی شبیه خروجی زیر دریافت کنید

server: 192.168.0.1

from: mikrotikbackup@yourhost.com

که "192.168.0.1" آدرس SMTPسرور شما و mikrottikbackup@yourhost.com ایملیل آدرسی هست که MTبرای شناسایی خودش وقتی backup ها را ارسال میکند استفاده خواهد کرد.اگر شما همچنین خروجی مشاهده نکردین شما باید تنظیمات مربوط به کانفیگ e-mail را با استفاده از دستور زیر انجام بدهید:

/tool e-mail

set server=192.168.0.1 from=mikrotikbackup@yourhost.com

در این قسمت شما باید اسکریپت های لازم برای ارسال ایمیل وارد کنید.طبق دستور زیر:

tool e-mail send to="youremail@yourhost.com" subject=([system identity get name]." backup") file=email.backup;

:log info "Backup e-mail sent."; {

بجای youremail@yourhost.com شما باید ایمیل مربوط به دریافت کننده را وارد کنید.اگر شما تصمیم داشته باشید از چند ایمیل ادرس استفاده کنید ،اجرا کنید دستورات زیر:

/system script

add name="e-mail-backup" source={/system backup save name=email;

tool e-mail send to="youremail1@yourhost.com" subject=([system identity get name]." backup") file=email.backup;

tool e-mail send to="youremail2@yourhost.com" subject=([system identity get name]." backup") file=email.backup;

tool e-mail send to="youremail3@yourhost.com" subject=([system identity get name]." Backup") file=email.backup;

:log info "Backup e-mail sent."; }

آخرین مرحله این است که config زمانبندی برای اجرای اسکریپت بالا در یک بازه زمانی است .اجرای دستور زیر باعث میشود هر روز اسکریپت اجرا شود:

/system scheduler

add comment="" disabled=no interval=1d name="e-mail-backup" \

on-event=e-mail-backup start-date=jan011970 start-time=00:00:00

وقتی انجام می شود، شما می توانید تنظیمات خود را در Winboxبررسی کنید، وباید به چیزی شبیه شکل زیر برسید:

وب سایت توسینسو
وب سایت توسینسو

Backup گیری از تنظیمات روتر میکروتیک

اول از همه، ما باید تمام روترهایی رو که نیاز به طور مکرر backup بگیرن رو کانفیگ کنیم. (در این مثال، من میخوام هر روز این کار انجام بده) برای این کار، ما این دستور در هر روتر را اجرا کنیم:

/system scheduler

add name="backup" on-event="system backup save name=today.backup" \

start-date=jan011970 start-time=00:00:00 interval=10h comment="" \

disabled=no

دستور بالا خیلی ساده است،یک فایل Backupمیکروتیک به نام "today.backup" که هر 10 ساعت انجام خواهد شد را ایجاد میکند. میتونیم به فایل های Backup توسط سرور اصلی ما از طریق FTP دسترسی داشته باشیم . با اجرای دستور زیر ما مطمئن خواهیم شد که همه چیز به درستی کار میکند:

/system backup save name=today.backup

خب بعد از این مرحله فایل backup باید ایجاد شده باشد. برای اطمینان به لیست فایل ها مراجع میکنم:

وب سایت توسینسو

در قسمت روتر تنظیمات تقریبا کامل است، اما باید مطمئن بشیم که دسترسی به FTP موجود است:

/ip service print

When the command is executed, the following output (or similar) should appear:

Flags: X - disabled, I - invalid

# NAME PORT ADDRESS CERTIFICATE

0 telnet 23 0.0.0.0/0

1 ftp 21 0.0.0.0/0

2 www 80 0.0.0.0/0

3 ssh 22 0.0.0.0/0

4 X www-ssl 443 0.0.0.0/0 none

5 X api 8728 0.0.0.0/0

6 winbox 8291 0.0.0.0/0

اگر هیچ "X" در کنار آیتم FTP در لیست ظاهر شده وجود نداشته باشد یعنی اماده برای انجام ادامه برنامه. توصیه میشود بدلایل امنیتی برای هر روتر بصورت مجزا یک FTP ایجاد کرده :

/user group

add name="ftp" policy=ftp,!local,!telnet,!ssh,!reboot,!read,!write,!policy,!test,!winbox,!password,!web,!sniff

/user

add address=0.0.0.0/0 comment="FTP backup" disabled=no group=ftp name="ftp"

/user

set [find name="ftp"] password="mypass"

تنظیمات سرور یا Server Configuration

حالا که روتر به طور کامل پیکربندی شده ،ما باید ی سری تنظیمات مربوط به میزبان فایل های Backup را روی ویندوز(میزبان پشتیبان گیری) انجام دهیم. اول از همه، دانلود "MTBACKUP"از اینجا mtbackup.exe نحوه استفاده "mtbackup.exe" بصورت زیر است:

Usage: mtbackup.exe [input ftp script template] [output ftp script] [destination backup folder] [windows FTP client path]

Example: mtbackup.exe "c:\example\template.s" "c:\example\script.s" "c:\mikrotik-backups" "C:\Windows\System32\ftp.exe"

کپی برنامه "mtbackup.exe" در یک پوشه موجود برای استفاده های بعدی. (در این مثال، مسیر “C:\mtbackup”)

آموزش ایجاد اسکریپت FTP

برای این کار میتونیم از یک روش خیلی ساده استفاده کنیم. Notepad را باز میکنیم و دستورات زیر رو تایپ میکنیم:

o 192.168.0.1 21

USER ftp

mypass

binary

$

192.168.0.1 – Router backup

close

quit

توضیحی در مورد اسکریپت FTP

  • o 192.168.0.1 21 : ایجاد کنید یک Connection روی سرور FTPروتر خودتون-192.168.0.1 در پورت 21
  • USER ftp : یک نام کاربری برای login کردن FTP انتخاب کنید
  • mypass : برای login کردن یک password انتخاب کنید
  • binary :استفاده کنید از Binary بجای ASCLL برای نگهداری از فایل های پشتیبان
  • $ : برای خاتمه این فرایند از علامت $ استفاده میکنیم
  • 192.168.0.1 – Router backup : نام فایل backup روتر
  • Close:اجازه ویرایش نده و ایجاد کن یک ارتباط مناسب با FTP client
  • Quit:باعث خروج از اجرای هر فرمان در FTP client ها

این فایلی که در Notpad ایجاد کردین را در یک مکان ذخیره کرد،توصیه میشه اسکریپت ها رو در فایل mtbackup.exe ذخیره کنید،در این مثال نام این فایل “mtscript.sمی باشد.اگر قصد داشته باشید چندین روتر داشته باشید کافیه اسکربپت ها رو پشت سرهم با یک خط خالی بنویسید،بعنوان مثال:

o 192.168.0.1 21

USER ftp

mypass1

binary

$

192.168.0.1 - Backup

close

o 192.168.0.2 21

USER ftp

mypass2

binary

$

192.168.0.2 - Backup

close

o 192.168.0.3 21

USER ftp

mypass3

binary

$

192.168.0.3 - Backup

close

quit

خب حالا که فایل اسکریپت اماده شد با استفاده از دستورات زیر یک تست سریع میگیریم:

C:\mtbackup\mtbackup.exe "c:\mtbackup\mtscript.s" "c:\mtbackup\script.s" "c:\mtbackup\backups"

اگر فایل ftp.exe در Windows’ FTP client در مسیر C:\windows\system32 قرار نگرفته بود،مسیر با استفاده از دستوارت زیر ویرایش کنید:

C:\mtbackup\mtbackup.exe "c:\mtbackup\mtscript.s" "c:\mtbackup\script.s" "c:\mtbackup\backups" "d:\windows\system32\ftp.exe"

بعد از اینکه این دستورات اجرا شد،توجه کنید که پوشه backup شامل تمام backup های دسته بندی شده توسط تاریخ وارد شده است.

Configuring Windows scheduler تنظیمات زمانبندی ویندوز 

خب حالا باید سایر تنظیمات را روی سرور 2008 (سروی که من استفاده میکنم)تنظیمات مربوط به زمان بندی Backup را انجام دهیم . از مسیر زیر وارد تنظیمات میشویم:

وب سایت توسینسو
وب سایت توسینسو
وب سایت توسینسو

در تصویر بالا در قسمت Name یک نام مناسب برای این کار انتخاب کنید،شما میتونید Description را بنویسید اما لزومی به انجام این کار نیست اما باید مطمئن باشید تیک مربوط به Run whether is logged on or not را زده باشید تا مطمئن باشید که اسکریپت ها اجرا میشه چه زمانی که کسی وارد سیستم نشه یا هنگام log on کردن.همچنین تیک مربوط به run with highest privileges را زده باشید با این گزینه شما مطمئن میشوید که اسکریپت ها به پوشه های ارسالی که توسط ویندوز محافظت میشه فرستاده میشه.

وب سایت توسینسو

در این صفحه روی دکمه new کلیک کرد

وب سایت توسینسو

در این قسمت شما میتونید تنظیمات رو انجام بدین،بعنوان مثلا چون من میخواستم هرروز اسکریپت ها اجرا بشه گزینه daily رو انتخاب کردم همچنین میتونید تاریخ و ساعت اجرا رو هم تعیین کنید.همچنیم شما میتونید بازدن تیک stop task if it rune longer than ی مدت زمانی را تعیین کنید و که اگه اجرای شما بیشتر از مدت مشخص شده طول کشید متوقف بشه چون احتمالا خطایی وجود دارد.سپس تنظیمات ok کنید.

وب سایت توسینسو

خب در این پنجره روی New کلیک کرده و یک actions جدید ایجاد میکنیم

وب سایت توسینسو

در این قسمت Action باید در حالت start a program باشد و از قسمت browse مسیر فایل mtbackup.exe را انتخاب میکنیم.در قسمت بعدی Add arguments اسکریپت زیر را وارد میکنیم:

"c:\mtbackup\mtscript.s" "c:\mtbackup\script.s" "c:\mtbackup\backups"

اگر هم فایل ftp.exe خارج از مسیر C:\windows\system32 hsj.ویرایش کنید اسکریپت بصورت زیر:

"c:\mtbackup\mtscript.s" "c:\mtbackup\script.s" "c:\mtbackup\backups" "d:\windows\system32\ftp.exe"

و در قسمت بعد Start in من مسیر پیشفرضی که انتخاب کردم رو وارد کردم بعد تنظیمات را ok میکنیم

وب سایت توسینسو

در این قسمت چک کنید تمام تنظیماتی که وارد کردید صحیح است ،اگر درست بود ok کنید در غیر اینصورت تنظیمات را دوباره انجام دهید و ویراش کنید.

Final adjustments تنظیمات نهایی FTP سرور

FTP - شما می توانید یک سرور FTP بر روی دستگاه خودکه میزبان پوشه Backup است اجرا کنید.

Hosting the backups on a secured FTP server
  • WEB - شما می توانید انتخاب کنید یک وب سرور مانند Apache برای فایل های Backup خودتون و بصورت online دریافت کنید و یا بر روی یک وب سرور محلی. با استفاده از mod_rewrite، شما می توانید آنها را با یک نام کاربری و رمز عبور protect کنید.
  • Nothing - شما میتونید به صورت مستقیم به فایل های خودتون دسترسی داشته باشید.

حالا شما تمام تنظیمات مربوط به Backup گیری اتوماتیک رو انجام دادین و اجرای آن از همین لحظه آغاز میشود .خب هر زمان که یک عاملی باعث خرابی سخت افزار یا هرگونه config اشتباهی رخ بده شما میتونید با استفاده از این backup به اخرین تنظیمات خودتون خیلی ساده و سریع دسترسی پیدا کنید. امیدوارم مفید واقع شده باشه.موفق و سربلند باشید.


الهام السادات زاهدی فرد
الهام السادات زاهدی فرد

هر روز در حستجو علم

هر طایفه ای به من گمانی دارد من زان خودم چنان که هستم،هستم

20 دی 1394 این مطلب را ارسال کرده

نظرات